Apache NiFi

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Apache NiFi

Zaciragic, Samir *
Hello,

We are FDA docker support team trying to assist internal teams to onboard their applications. We were able to pull latest apache NiFi (1.8.0) and run container manually, but we faced an issue to use docker-compose to start the service. One of our teammates found that older version of apache Nifi (1.4.0) works, but none of newer versions due to the fact that newer version have some security features that prevent docker service to run properly.

Is there some particular setup we are missing, that would help run the service with newer version? Any assistance would be greatly appreciated.

Thank you!
Reply | Threaded
Open this post in threaded view
|

Re: Apache NiFi

Mike Thomsen
Samir,

Can you be more specific, preferably posting some logs?

Thanks,

Mike

On Wed, Dec 12, 2018 at 12:13 PM Zaciragic, Samir * <
[hidden email]> wrote:

> Hello,
>
> We are FDA docker support team trying to assist internal teams to onboard
> their applications. We were able to pull latest apache NiFi (1.8.0) and run
> container manually, but we faced an issue to use docker-compose to start
> the service. One of our teammates found that older version of apache Nifi
> (1.4.0) works, but none of newer versions due to the fact that newer
> version have some security features that prevent docker service to run
> properly.
>
> Is there some particular setup we are missing, that would help run the
> service with newer version? Any assistance would be greatly appreciated.
>
> Thank you!
>
Reply | Threaded
Open this post in threaded view
|

Re: Apache NiFi

Aldrin Piri
Based on the versions that worked/didn't work, I am assuming this concerns
the host header protections that was covered in NIFI-4761 and then made
configurable to our Docker image in NIFI-4788.  What changed is detailed in
the admin guide toward the bottom of the Proxy Configuration section [3].

If this doesn't quite seem to coincide with what you are experiencing, more
information (inclusive of compose file, if possible) would be great.

[1] https://issues.apache.org/jira/browse/NIFI-4761
[2] https://issues.apache.org/jira/browse/NIFI-4788
[3]
https://github.com/mcgilman/nifi/blob/acb19a91fc7908e10dbc2b4364daa1657fc7657b/nifi-docs/src/main/asciidoc/administration-guide.adoc#proxy-configuration

On Wed, Dec 12, 2018 at 1:09 PM Mike Thomsen <[hidden email]> wrote:

> Samir,
>
> Can you be more specific, preferably posting some logs?
>
> Thanks,
>
> Mike
>
> On Wed, Dec 12, 2018 at 12:13 PM Zaciragic, Samir * <
> [hidden email]> wrote:
>
> > Hello,
> >
> > We are FDA docker support team trying to assist internal teams to onboard
> > their applications. We were able to pull latest apache NiFi (1.8.0) and
> run
> > container manually, but we faced an issue to use docker-compose to start
> > the service. One of our teammates found that older version of apache Nifi
> > (1.4.0) works, but none of newer versions due to the fact that newer
> > version have some security features that prevent docker service to run
> > properly.
> >
> > Is there some particular setup we are missing, that would help run the
> > service with newer version? Any assistance would be greatly appreciated.
> >
> > Thank you!
> >
>