NIFI code build error

classic Classic list List threaded Threaded
9 messages Options
cpk
Reply | Threaded
Open this post in threaded view
|

NIFI code build error

cpk
Hi,

I downloaded code from http://nifi.incubator.apache.org/downloads/ and ran
mvn clean install from root folder nifi-0.0.1-incubating/. Getting the
below build error


[ERROR] Failed to execute goal
net.alchim31.maven:yuicompressor-maven-plugin:1.1
:compress (minify) on project nifi-web-ui: Unable to parse configuration of
mojo
 net.alchim31.maven:yuicompressor-maven-plugin:1.1:compress for parameter
aggreg
ation: Cannot create instance of class
net_alchim31_maven_yuicompressor.Aggregat
ion: org/codehaus/plexus/util/DirectoryScanner:
org.codehaus.plexus.util.Directo
ryScanner -> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute
goal n
et.alchim31.maven:yuicompressor-maven-plugin:1.1:compress (minify) on
project ni
fi-web-ui: Unable to parse configuration of mojo
net.alchim31.maven:yuicompresso
r-maven-plugin:1.1:compress for parameter aggregation: Cannot create
instance of
 class net_alchim31_maven_yuicompressor.Aggregation
        at
org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor
.java:220)
        at
org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor
.java:153)
        at
org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor
.java:145)
        at
org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProje
ct(LifecycleModuleBuilder.java:84)




Pls help on this.

Thanks & Regards,
Pavan
Reply | Threaded
Open this post in threaded view
|

Re: NIFI code build error

Matt Gilman
Pavan,

It appears to be having trouble with the maven YUI compressor plugin. Was
there any additional details provided? Can you provide more details about
your environment? Maybe provide the output of mvn -version. Thanks.

Matt

On Mon, Feb 2, 2015 at 12:26 PM, Pavan Chenduluru <[hidden email]>
wrote:

> Hi,
>
> I downloaded code from http://nifi.incubator.apache.org/downloads/ and ran
> mvn clean install from root folder nifi-0.0.1-incubating/. Getting the
> below build error
>
>
> [ERROR] Failed to execute goal
> net.alchim31.maven:yuicompressor-maven-plugin:1.1
> :compress (minify) on project nifi-web-ui: Unable to parse configuration of
> mojo
>  net.alchim31.maven:yuicompressor-maven-plugin:1.1:compress for parameter
> aggreg
> ation: Cannot create instance of class
> net_alchim31_maven_yuicompressor.Aggregat
> ion: org/codehaus/plexus/util/DirectoryScanner:
> org.codehaus.plexus.util.Directo
> ryScanner -> [Help 1]
> org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute
> goal n
> et.alchim31.maven:yuicompressor-maven-plugin:1.1:compress (minify) on
> project ni
> fi-web-ui: Unable to parse configuration of mojo
> net.alchim31.maven:yuicompresso
> r-maven-plugin:1.1:compress for parameter aggregation: Cannot create
> instance of
>  class net_alchim31_maven_yuicompressor.Aggregation
>         at
> org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor
> .java:220)
>         at
> org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor
> .java:153)
>         at
> org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor
> .java:145)
>         at
> org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProje
> ct(LifecycleModuleBuilder.java:84)
>
>
>
>
> Pls help on this.
>
> Thanks & Regards,
> Pavan
>
cpk
Reply | Threaded
Open this post in threaded view
|

Fwd: NIFI code build error

cpk
In reply to this post by cpk
Hello...Can any body read these mails??? if so please reply me..

---------- Forwarded message ----------
From: Pavan Chenduluru <[hidden email]>
Date: Mon, Feb 2, 2015 at 10:56 PM
Subject: NIFI code build error
To: [hidden email]


Hi,

I downloaded code from http://nifi.incubator.apache.org/downloads/ and ran
mvn clean install from root folder nifi-0.0.1-incubating/. Getting the
below build error


[ERROR] Failed to execute goal
net.alchim31.maven:yuicompressor-maven-plugin:1.1
:compress (minify) on project nifi-web-ui: Unable to parse configuration of
mojo
 net.alchim31.maven:yuicompressor-maven-plugin:1.1:compress for parameter
aggreg
ation: Cannot create instance of class
net_alchim31_maven_yuicompressor.Aggregat
ion: org/codehaus/plexus/util/DirectoryScanner:
org.codehaus.plexus.util.Directo
ryScanner -> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute
goal n
et.alchim31.maven:yuicompressor-maven-plugin:1.1:compress (minify) on
project ni
fi-web-ui: Unable to parse configuration of mojo
net.alchim31.maven:yuicompresso
r-maven-plugin:1.1:compress for parameter aggregation: Cannot create
instance of
 class net_alchim31_maven_yuicompressor.Aggregation
        at
org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor
.java:220)
        at
org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor
.java:153)
        at
org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor
.java:145)
        at
org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProje
ct(LifecycleModuleBuilder.java:84)




Pls help on this.

Thanks & Regards,
Pavan
Reply | Threaded
Open this post in threaded view
|

Re: NIFI code build error

Joe Witt
Pavan,

Please subscribe to the mailing list so you will receive the responses.
You may also view the messages in the archive.  See here for more
information and in the archive you'll see the response to your last message.

http://nifi.incubator.apache.org/mailing_lists.html

http://mail-archives.apache.org/mod_mbox/incubator-nifi-dev/201502.mbox/%3CCAFddr24nBXvexuk7pD0tYTSA6Z73OK9eHbEYmgvbo3EwTH4Hxg%40mail.gmail.com%3E

Thanks
Joe

On Mon, Feb 2, 2015 at 11:45 PM, Pavan Chenduluru <[hidden email]>
wrote:

> Hello...Can any body read these mails??? if so please reply me..
>
> ---------- Forwarded message ----------
> From: Pavan Chenduluru <[hidden email]>
> Date: Mon, Feb 2, 2015 at 10:56 PM
> Subject: NIFI code build error
> To: [hidden email]
>
>
> Hi,
>
> I downloaded code from http://nifi.incubator.apache.org/downloads/ and ran
> mvn clean install from root folder nifi-0.0.1-incubating/. Getting the
> below build error
>
>
> [ERROR] Failed to execute goal
> net.alchim31.maven:yuicompressor-maven-plugin:1.1
> :compress (minify) on project nifi-web-ui: Unable to parse configuration of
> mojo
>  net.alchim31.maven:yuicompressor-maven-plugin:1.1:compress for parameter
> aggreg
> ation: Cannot create instance of class
> net_alchim31_maven_yuicompressor.Aggregat
> ion: org/codehaus/plexus/util/DirectoryScanner:
> org.codehaus.plexus.util.Directo
> ryScanner -> [Help 1]
> org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute
> goal n
> et.alchim31.maven:yuicompressor-maven-plugin:1.1:compress (minify) on
> project ni
> fi-web-ui: Unable to parse configuration of mojo
> net.alchim31.maven:yuicompresso
> r-maven-plugin:1.1:compress for parameter aggregation: Cannot create
> instance of
>  class net_alchim31_maven_yuicompressor.Aggregation
>         at
> org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor
> .java:220)
>         at
> org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor
> .java:153)
>         at
> org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor
> .java:145)
>         at
> org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProje
> ct(LifecycleModuleBuilder.java:84)
>
>
>
>
> Pls help on this.
>
> Thanks & Regards,
> Pavan
>
cpk
Reply | Threaded
Open this post in threaded view
|

Re: NIFI code build error

cpk
In reply to this post by Matt Gilman
Hi,

Thanks for your reply.

Below are my local environment details

OS: windows 8
Java: 1.7.0_45
Maven: apache-maven-3.2.5

Thanks & Regards,
Pavan
Reply | Threaded
Open this post in threaded view
|

Re: NIFI code build error

Matt Gilman
Pavan,

That environment certainly shouldn't be a problem. I just upgraded to maven
3.2.5 to confirm that weren't any incompatibles between maven and that
version of the YUI compressor plugin. Everything still built without issue.
I did notice that the version of that plugin is quite old. I will be
updating that for our next release [1]. Unfortunately, I am not able to
replicate your exact environment as I am running on OSX but I know that
others haven't had issues on Windows.

Based on the information you've provided, I do not know what the problem
is. However, I can offer these suggestions...

- Confirm that the YUI compressor plugin in your local repository is
correct by verifying the hashes.
- Run maven with the debug flag set (-X). This will create incredibly
verbose output so you'll want to redirect it to a file. You should then be
able to find the part where the YUI compressor is being invoked and there
may be more details there. Unfortunately from the standard output all we
know is that it couldn't create an instance of
net_alchim31_maven_yuicompressor.Aggregation
but it doesn't say why.

If these suggestions don't help, as a workaround you can build with the
'minify-and-compress' profile disabled. This profile is active by default
but when disabled, it will not minify and compress any of the CSS and JS
allowing for easier development but not recommended for production use.

[1] https://issues.apache.org/jira/browse/NIFI-315


On Tue, Feb 3, 2015 at 12:01 AM, chenduluru <[hidden email]> wrote:

> Hi,
>
> Thanks for your reply.
>
> Below are my local environment details
>
> OS: windows 8
> Java: 1.7.0_45
> Maven: apache-maven-3.2.5
>
> Thanks & Regards,
> Pavan
>
>
>
> --
> View this message in context:
> http://apache-nifi-incubating-developer-list.39713.n7.nabble.com/NIFI-code-build-error-tp536p545.html
> Sent from the Apache NiFi (incubating) Developer List mailing list archive
> at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|

Re: NIFI code build error

Matt Gilman
Pavan,

Two additional thoughts.

- Could the issue be caused to a lengthy file path?
- Maybe try setting your MAVEN_OPTS in case it's running out of memory...

MAVEN_OPTS="-Xms1024m -Xmx3076m -XX:MaxPermSize=256m"


On Tue, Feb 3, 2015 at 7:52 AM, Matt Gilman <[hidden email]> wrote:

> Pavan,
>
> That environment certainly shouldn't be a problem. I just upgraded to
> maven 3.2.5 to confirm that weren't any incompatibles between maven and
> that version of the YUI compressor plugin. Everything still built without
> issue. I did notice that the version of that plugin is quite old. I will be
> updating that for our next release [1]. Unfortunately, I am not able to
> replicate your exact environment as I am running on OSX but I know that
> others haven't had issues on Windows.
>
> Based on the information you've provided, I do not know what the problem
> is. However, I can offer these suggestions...
>
> - Confirm that the YUI compressor plugin in your local repository is
> correct by verifying the hashes.
> - Run maven with the debug flag set (-X). This will create incredibly
> verbose output so you'll want to redirect it to a file. You should then be
> able to find the part where the YUI compressor is being invoked and there
> may be more details there. Unfortunately from the standard output all we
> know is that it couldn't create an instance of net_alchim31_maven_yuicompressor.Aggregation
> but it doesn't say why.
>
> If these suggestions don't help, as a workaround you can build with the
> 'minify-and-compress' profile disabled. This profile is active by default
> but when disabled, it will not minify and compress any of the CSS and JS
> allowing for easier development but not recommended for production use.
>
> [1] https://issues.apache.org/jira/browse/NIFI-315
>
>
> On Tue, Feb 3, 2015 at 12:01 AM, chenduluru <[hidden email]> wrote:
>
>> Hi,
>>
>> Thanks for your reply.
>>
>> Below are my local environment details
>>
>> OS: windows 8
>> Java: 1.7.0_45
>> Maven: apache-maven-3.2.5
>>
>> Thanks & Regards,
>> Pavan
>>
>>
>>
>> --
>> View this message in context:
>> http://apache-nifi-incubating-developer-list.39713.n7.nabble.com/NIFI-code-build-error-tp536p545.html
>> Sent from the Apache NiFi (incubating) Developer List mailing list
>> archive at Nabble.com.
>>
>
>
Reply | Threaded
Open this post in threaded view
|

Re: NIFI code build error

Joe Witt
matt - good call.  To that end I've updated the quickstart guide with that
info.

On Tue, Feb 3, 2015 at 9:15 AM, Matt Gilman <[hidden email]> wrote:

> Pavan,
>
> Two additional thoughts.
>
> - Could the issue be caused to a lengthy file path?
> - Maybe try setting your MAVEN_OPTS in case it's running out of memory...
>
> MAVEN_OPTS="-Xms1024m -Xmx3076m -XX:MaxPermSize=256m"
>
>
> On Tue, Feb 3, 2015 at 7:52 AM, Matt Gilman <[hidden email]>
> wrote:
>
> > Pavan,
> >
> > That environment certainly shouldn't be a problem. I just upgraded to
> > maven 3.2.5 to confirm that weren't any incompatibles between maven and
> > that version of the YUI compressor plugin. Everything still built without
> > issue. I did notice that the version of that plugin is quite old. I will
> be
> > updating that for our next release [1]. Unfortunately, I am not able to
> > replicate your exact environment as I am running on OSX but I know that
> > others haven't had issues on Windows.
> >
> > Based on the information you've provided, I do not know what the problem
> > is. However, I can offer these suggestions...
> >
> > - Confirm that the YUI compressor plugin in your local repository is
> > correct by verifying the hashes.
> > - Run maven with the debug flag set (-X). This will create incredibly
> > verbose output so you'll want to redirect it to a file. You should then
> be
> > able to find the part where the YUI compressor is being invoked and there
> > may be more details there. Unfortunately from the standard output all we
> > know is that it couldn't create an instance of
> net_alchim31_maven_yuicompressor.Aggregation
> > but it doesn't say why.
> >
> > If these suggestions don't help, as a workaround you can build with the
> > 'minify-and-compress' profile disabled. This profile is active by default
> > but when disabled, it will not minify and compress any of the CSS and JS
> > allowing for easier development but not recommended for production use.
> >
> > [1] https://issues.apache.org/jira/browse/NIFI-315
> >
> >
> > On Tue, Feb 3, 2015 at 12:01 AM, chenduluru <[hidden email]>
> wrote:
> >
> >> Hi,
> >>
> >> Thanks for your reply.
> >>
> >> Below are my local environment details
> >>
> >> OS: windows 8
> >> Java: 1.7.0_45
> >> Maven: apache-maven-3.2.5
> >>
> >> Thanks & Regards,
> >> Pavan
> >>
> >>
> >>
> >> --
> >> View this message in context:
> >>
> http://apache-nifi-incubating-developer-list.39713.n7.nabble.com/NIFI-code-build-error-tp536p545.html
> >> Sent from the Apache NiFi (incubating) Developer List mailing list
> >> archive at Nabble.com.
> >>
> >
> >
>
cpk
Reply | Threaded
Open this post in threaded view
|

Re: NIFI code build error

cpk
Thanks for your response.

Actually issue with my maven local repository. I update new maven repository in settings.xml file in my local and now build successful.

once again thanks for your help and quick response.