NiFi unsecure cluster setup issue on Windows.

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

NiFi unsecure cluster setup issue on Windows.

shahbazatta
Hi,
I am trying to setup the 3 node NiFi but i am unable to set it up. I already setup it on ubuntu and it is working fine but the same configurations not working on windows machines.

I tried restarting all nodes, nifi service, etc but nothing works:

Failed to determine which node is elected active Cluster Coordinator: ZooKeeper reports the address as winifi01:9999

whereas, winifi01 node showing cluster of 1/1. i also verify the hosts file and zookeeper properties

zookeer.properties
server.1=winifi01:2888:3888
server.2=winifi02:2888:3888
server.3=winifi03:2888:3888

Reply | Threaded
Open this post in threaded view
|

Re: NiFi unsecure cluster setup issue on Windows.

Andre
Hi,



could it be that the windows firewall is enabled and blocking the ZK
communication between nodes?

Cheers

On Wed, May 3, 2017 at 10:53 PM, shahbazatta <[hidden email]> wrote:

> Hi,
> I am trying to setup the 3 node NiFi but i am unable to set it up. I
> already
> setup it on ubuntu and it is working fine but the same configurations not
> working on windows machines.
>
> I tried restarting all nodes, nifi service, etc but nothing works:
>
> Failed to determine which node is elected active Cluster Coordinator:
> ZooKeeper reports the address as winifi01:9999
>
> whereas, winifi01 node showing cluster of 1/1. i also verify the hosts file
> and zookeeper properties
>
> zookeer.properties
> server.1=winifi01:2888:3888
> server.2=winifi02:2888:3888
> server.3=winifi03:2888:3888
>
>
>
>
>
> --
> View this message in context: http://apache-nifi-developer-
> list.39713.n7.nabble.com/NiFi-unsecure-cluster-setup-issue-
> on-Windows-tp15631.html
> Sent from the Apache NiFi Developer List mailing list archive at
> Nabble.com.
>