Nifi config issues

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Nifi config issues

McGary, Ryan - US
Hello,

                My company is in the process of standing up a Test environment, and we're installing Nifi on one of our Rhel7 servers.  We are running into some issues, however.  When Nifi is configured for http, it runs just fine, but as soon as we change the config to https it starts putting out errors.  We think we have the Key/truststore configured correctly, but after we start the nifi service we continuously get the "org.apache.nifi.web.NiFiCoreException: Unable to start Flow Controller." error.  Googling brought up many different responses, but none of them seemed to fix our problem.  Just wondering if the developers could help, or perhaps point me in the right direction? Any help would be much appreciated, thanks.

v/r

Ryan McGary
Reply | Threaded
Open this post in threaded view
|

Re: Nifi config issues

Joe Witt
ryan

we'll likely need to see the full stack trace and a good bit more
context on the configuration.

nifi on rel7 is an extremely common deployment scenario so that part
is good/easy and now it is likely a matter of config.

Thanks
On Wed, Oct 3, 2018 at 12:18 PM McGary, Ryan - US <[hidden email]> wrote:
>
> Hello,
>
>                 My company is in the process of standing up a Test environment, and we're installing Nifi on one of our Rhel7 servers.  We are running into some issues, however.  When Nifi is configured for http, it runs just fine, but as soon as we change the config to https it starts putting out errors.  We think we have the Key/truststore configured correctly, but after we start the nifi service we continuously get the "org.apache.nifi.web.NiFiCoreException: Unable to start Flow Controller." error.  Googling brought up many different responses, but none of them seemed to fix our problem.  Just wondering if the developers could help, or perhaps point me in the right direction? Any help would be much appreciated, thanks.
>
> v/r
>
> Ryan McGary
Reply | Threaded
Open this post in threaded view
|

Re: Nifi config issues

Andy LoPresto-2
Ryan,

As Joe mentioned, we’ll need to see the full stacktrace, but the problem is likely at the bottom of that error output. The Flow Controller is a critical piece of NiFi’s architecture, and errors with loading it are usually because of a missing or misconfigured value. I’m guessing that your authorizers.xml or login-identity-providers.xml file is misconfigured, and that causes a chain of errors in the bean loading that bubbles up to the FC error you’re seeing. The most specific error (usually at the root of the stacktrace) is the one you want to address. 

Hope this helps, and we’ll be happy to look at the stacktrace when you share it. 


Andy LoPresto
PGP Fingerprint: 70EC B3E5 98A6 5A3F D3C4  BACE 3C6E F65B 2F7D EF69

On Oct 3, 2018, at 9:19 AM, Joe Witt <[hidden email]> wrote:

ryan

we'll likely need to see the full stack trace and a good bit more
context on the configuration.

nifi on rel7 is an extremely common deployment scenario so that part
is good/easy and now it is likely a matter of config.

Thanks
On Wed, Oct 3, 2018 at 12:18 PM McGary, Ryan - US <[hidden email]> wrote:

Hello,

               My company is in the process of standing up a Test environment, and we're installing Nifi on one of our Rhel7 servers.  We are running into some issues, however.  When Nifi is configured for http, it runs just fine, but as soon as we change the config to https it starts putting out errors.  We think we have the Key/truststore configured correctly, but after we start the nifi service we continuously get the "org.apache.nifi.web.NiFiCoreException: Unable to start Flow Controller." error.  Googling brought up many different responses, but none of them seemed to fix our problem.  Just wondering if the developers could help, or perhaps point me in the right direction? Any help would be much appreciated, thanks.

v/r

Ryan McGary


signature.asc (849 bytes) Download Attachment