Plain Expression Language is not getting evaluated

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Plain Expression Language is not getting evaluated

Kannan Ramamoorthy
Dear Dev Team,

I am facing an issue that plain Expression language is not getting
evaluated. The situation is, whenever I give just the expression
laguage *${MY_ENV_VAR},
*the expression is not getting evaluated. Whereas it is getting evaluated
when there is additional charaecter, along with the EL. Also posted it in
Stackoverflow <http:///etc/secrets/quant-trust-store.jks>.

Kindly let me know if this is a bug or am I doing something wrong?

Regards,
Kannan
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Plain Expression Language is not getting evaluated

Pierre Villard
Hi Kannan,

In what processor and what property are you trying to use EL?
By hovering the question mark next to the property, is it specified that
expression language is supported?
If using an environment variable, did you restart NiFi after setting the
variable?

Thanks!

2017-08-08 12:54 GMT+02:00 Kannan Ramamoorthy <[hidden email]>:

> Dear Dev Team,
>
> I am facing an issue that plain Expression language is not getting
> evaluated. The situation is, whenever I give just the expression
> laguage *${MY_ENV_VAR},
> *the expression is not getting evaluated. Whereas it is getting evaluated
> when there is additional charaecter, along with the EL. Also posted it in
> Stackoverflow <http:///etc/secrets/quant-trust-store.jks>.
>
> Kindly let me know if this is a bug or am I doing something wrong?
>
> Regards,
> Kannan
>
Loading...