Provenance Request Issues

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Provenance Request Issues

Donaldson, Michael

Hi there,

 

I am having issues getting a response from the API when looking for Provenance results.

 

When I get the status of a processor, it works fine:

 

However if I try to get the data provenance results (taking the exact Request URL from browser network viewer), I get a code 500 error:

 

Is there a problem with the endpoint? If not, why am I not seeing the results that my browser tells me I should expect?

 

All authorization is the same as the successful request above.

 

Many thanks,

Mike

 

Mike Donaldson | Test Analyst | McLaren Technology Group Limited

McLaren Technology Centre, Chertsey Road, Woking, Surrey, GU21 4YH, UK

 

T  +44 (0) 1483 262342

M +44 (0) 7557490104

E  [hidden email]

W www.mclaren.com

 


The contents of this e-mail are confidential and for the exclusive use of the intended recipient. If you are not the intended recipient you should not read, copy, retransmit or disclose its contents. If you have received this email in error please delete it from your system immediately and notify us either by email or telephone. The views expressed in this communication may not necessarily be the views held by McLaren Applied Technologies Limited.
McLaren Applied Technologies Limited | McLaren Technology Centre | Chertsey Road | Woking | Surrey | GU21 4YH | UK | Company Number: 02322992
Reply | Threaded
Open this post in threaded view
|

Re: Provenance Request Issues

Bryan Bende
Hello,

If you are getting a 500 error there should be an error in the nifi-app.log
or nifi-user.log that corresponds to this.

Can you provide the error message and stacktrace from the logs?

Thanks,

Bryan


On Tue, Nov 20, 2018 at 8:43 AM Donaldson, Michael <
[hidden email]> wrote:

> Hi there,
>
>
>
> I am having issues getting a response from the API when looking for
> Provenance results.
>
>
>
> When I get the status of a processor, it works fine:
>
>
>
> However if I try to get the data provenance results (taking the exact
> Request URL from browser network viewer), I get a code 500 error:
>
>
>
> Is there a problem with the endpoint? If not, why am I not seeing the
> results that my browser tells me I should expect?
>
>
>
> All authorization is the same as the successful request above.
>
>
>
> Many thanks,
>
> Mike
>
>
>
> [image: cid:image002.jpg@01D46153.2CFB8D10]
>
> *Mike Donaldson | Test Analyst | McLaren **Technology Group Limited *
>
> McLaren Technology Centre, Chertsey Road, Woking, Surrey, GU21 4YH, UK
>
>
>
> T  +44 (0) 1483 262342
>
> M +44 (0) 7557490104
>
> E  *[hidden email] <[hidden email]>*
>
> W www.mclaren.com
>
>
>
> The contents of this e-mail are confidential and for the exclusive use of
> the intended recipient. If you are not the intended recipient you should
> not read, copy, retransmit or disclose its contents. If you have received
> this email in error please delete it from your system immediately and
> notify us either by email or telephone. The views expressed in this
> communication may not necessarily be the views held by McLaren Applied
> Technologies Limited.
> McLaren Applied Technologies Limited | McLaren Technology Centre |
> Chertsey Road | Woking | Surrey | GU21 4YH | UK | Company Number: 02322992
>