The import org.apache.nifi.expression.ExpressionLanguageScope cannot be resolved.

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

The import org.apache.nifi.expression.ExpressionLanguageScope cannot be resolved.

RITIKA NIWAS
I am getting an error. *The import
org.apache.nifi.expression.ExpressionLanguageScope** cannot be resolved*. I
already tried using this dependency  but the error is not resolved

<!--
https://mvnrepository.com/artifact/org.apache.nifi/nifi-expression-language
-->
<dependency>
    <groupId>org.apache.nifi</groupId>
    <artifactId>nifi-expression-language</artifactId>
    <version>1.5.0</version>
</dependency>

Link:
https://mvnrepository.com/artifact/org.apache.nifi/nifi-expression-language/1.5.0



Reply | Threaded
Open this post in threaded view
|

Re: The import org.apache.nifi.expression.ExpressionLanguageScope cannot be resolved.

Mike Thomsen
That particularly class is in 1.7.0-SNAPSHOT, not 1.5.0. You'd have to
download the code from GitHub and build it to get that version. If you're
writing a custom NAR, you don't need to worry about that until you move to
1.7.0.

On Wed, Apr 18, 2018 at 10:07 AM RITIKA NIWAS <[hidden email]> wrote:

> I am getting an error. *The import
> org.apache.nifi.expression.ExpressionLanguageScope** cannot be resolved*. I
> already tried using this dependency  but the error is not resolved
>
> <!--
> https://mvnrepository.com/artifact/org.apache.nifi/nifi-expression-language
> -->
> <dependency>
>     <groupId>org.apache.nifi</groupId>
>     <artifactId>nifi-expression-language</artifactId>
>     <version>1.5.0</version>
> </dependency>
>
> Link:
>
> https://mvnrepository.com/artifact/org.apache.nifi/nifi-expression-language/1.5.0
>
>
> ‌
>